株式会社タフス

CiscoでPPPoEサーバ

CiscoでPPPoEサーバ

検証でPPPoEサーバを使うことがありますが、
Ciscoでもできるんですね。知りませんでした。
なので、メモ。

username 0001@test.com password 0 test1
username 0002@test.com password 0 test2
username 0003@test.com password 0 test3
username 0004@test.com password 0 test4
username 0005@test.com password 0 test5
username yamaha password 0 yamaha
username yamaha2 password 0 yamaha2
!
bba-group pppoe global
virtual-template 1
ac name 0001@test.com
!
bba-group pppoe 0002
virtual-template 2
!
bba-group pppoe 0001
virtual-template 3
!
bba-group pppoe yamaha
virtual-template 6
!
bba-group pppoe yamaha2
virtual-template 7
!
bba-group pppoe tokyo
virtual-template 4
!
bba-group pppoe osaka
virtual-template 5
!
interface FastEthernet2
switchport access vlan 2
!
!
interface FastEthernet3
switchport access vlan 3
!
!
interface FastEthernet4
switchport access vlan 4
!
!
interface FastEthernet5
switchport access vlan 5
!
!
interface FastEthernet6
switchport access vlan 6
!
!
interface FastEthernet7
switchport access vlan 7
!
!
interface FastEthernet8
ip address 128.3.7.1 255.255.255.252
duplex auto
speed auto
pppoe enable group global
!
!
interface Virtual-Template1
mtu 1454
ip unnumbered FastEthernet8
peer default ip address pool test-5
ppp authentication chap
!
!
interface Virtual-Template2
mtu 1454
ip unnumbered Vlan2
peer default ip address pool test-2
ppp authentication chap
!
!
interface Virtual-Template3
mtu 1454
ip unnumbered Vlan1
peer default ip address pool test-1
ppp authentication chap
!
!
interface Virtual-Template4
mtu 1454
ip unnumbered Vlan4
peer default ip address pool tokyo
ppp authentication chap
!
!
interface Virtual-Template5
mtu 1454
ip unnumbered Vlan5
peer default ip address pool osaka
ppp authentication chap
!
!
interface Virtual-Template6
mtu 1454
ip unnumbered Vlan6
peer default ip address pool yamaha
ppp authentication chap
!
!
interface Virtual-Template7
mtu 1454
ip unnumbered Vlan7
peer default ip address pool yamaha2
ppp authentication chap
!
!
interface GigabitEthernet0
ip address 10.10.10.10 255.255.255.0
duplex auto
speed auto
!
!
interface Vlan1
ip address 128.1.1.5 255.255.255.252
pppoe enable group 0001
!
!
interface Vlan2
ip address 128.2.2.9 255.255.255.252
pppoe enable group 0002
!
!
interface Vlan3
ip address 128.3.3.13 255.255.255.252
!
!
interface Vlan4
ip address 128.4.4.1 255.255.255.252
pppoe enable group tokyo
!
!
interface Vlan5
ip address 128.5.5.1 255.255.255.252
pppoe enable group osaka
!
!
interface Vlan6
ip address 128.2.2.1 255.255.255.252
pppoe enable group yamaha
!
!
interface Vlan7
ip address 128.8.8.1 255.255.255.252
pppoe enable group yamaha2
!
!
ip local pool test-1 1.1.1.1
ip local pool test-2 1.1.1.2
ip local pool test-3 1.1.1.3
ip local pool test-4 1.1.1.4
ip local pool test-5 1.1.1.5
ip local pool yamaha 128.2.2.2
ip local pool yamaha2 128.8.8.2
ip local pool tokyo 2.2.2.2
ip local pool osaka 3.3.3.3

ちなみにOSは、
c890-universalk9-mz.150-1.M5.bin”